Author Topic: VLC high security warning  (Read 1866 times)

Offline ssfc72

  • Posting Member
  • Hero Member
  • *
  • Posts: 1033
  • Karma: +0/-0
    • View Profile
VLC high security warning
« on: July 26, 2019, 06:58:12 am »
https://www.computing.co.uk/ctg/news/3079319/vlc-critical-security-flaw

A very dangerous security flaw has been found in the VLC player. The fix should be coming shortly.
I  see this morning that my Mint 19 has a security update for VLC,  Mint 18 has not yet issued a security update, as of this morning.
« Last Edit: July 26, 2019, 07:17:33 am by ssfc72 »
Mint 18.3 on an HP Pavilion X360, 11" k120ca notebook
Tried Mint 19, but too many bugs. Went back to Mint 18.3
Cellphone ZTE Axon 7 Mini, PCMobile pay as you go

Offline Jason Wallwork

  • President
  • Administrator
  • Hero Member
  • *****
  • Posts: 2142
  • Karma: +5/-0
    • View Profile
Re: VLC high security warning
« Reply #1 on: July 26, 2019, 07:56:24 am »
Thanks for sharing although it looks like now that VLC set the specific flaws referred to were fixed 16 months ago. There's an update to the story but you need to have a registered account to view it.
Primary: Dell Desktop i5 - 3.2 GHz w/ Kubuntu 19.04 / Win 10 Pro
Secondary/Test:  Toshiba i3 - 1.4 GHz w/ Windows 10 Pro and Linux Du Jour (Ubuntu 19.10 right now)
Sony Xperia XA1 Ultra ( Android 8 ) on Freedom
Huawei MediaPad T3 10 ( Android 7 ) on Virgin

Offline ssfc72

  • Posting Member
  • Hero Member
  • *
  • Posts: 1033
  • Karma: +0/-0
    • View Profile
VLC high security warning
« Reply #2 on: July 26, 2019, 10:52:24 am »
Apparently the latest VLC version 3.0.7.1 is not affected, accordong to the VLC people
If you are have an older version of VLC, it may be vulnerable but CERT has reduced their advisory to a low level.
My VLC on Mint 18 is version 2.2.2
« Last Edit: July 26, 2019, 12:23:08 pm by ssfc72 »
Mint 18.3 on an HP Pavilion X360, 11" k120ca notebook
Tried Mint 19, but too many bugs. Went back to Mint 18.3
Cellphone ZTE Axon 7 Mini, PCMobile pay as you go