Author Topic: Main website issues - September 13, 2018  (Read 240 times)

Offline Jason Wallwork

  • Administrator
  • Hero Member
  • *****
  • Posts: 1365
  • Karma: +4/-0
    • View Profile
Main website issues - September 13, 2018
« on: September 13, 2018, 06:59:58 am »
Not sure what is going on but it when you go to http://plugintolinux.ca or just type in plugintolinux,ca, it redirects to a mailing list that no longer exists instead of showing the menu and content. There is a workaround until I get this fixed - just go to https://plugintolinux.ca instead (the SSL version of the website).

Should have this fixed by tomorrow. I'll reinstall Drupal if I have to.
Primary: Desktop Tower with Kubuntu 18.10 on i5-3470 3.2 Ghz with 12 GB RAM, 64 GB SSD for OSes, 4 TB RAID-10 array for programs/data

Secondary/Test: Toshiba Satellite Ultrabook Z830-00K w/ Linux Du Jour, (i3-2367M 1.4 GHz, 4GB DDR3, 128GB SDD)

Offline ssfc72

  • Posting Member
  • Hero Member
  • *
  • Posts: 711
  • Karma: +0/-0
    • View Profile
Re: Main website issues - September 13, 2018
« Reply #1 on: September 13, 2018, 11:46:42 am »
On my Opera browser, on my Android phone, typing in that url brings up the main PLUG web page.
Mint 18.3 on an HP Pavilion X360, 11" k120ca notebook
Cellphone ZTE Axon 7 Mini, PCMobile pay as you go

Offline Jason Wallwork

  • Administrator
  • Hero Member
  • *****
  • Posts: 1365
  • Karma: +4/-0
    • View Profile
Re: Main website issues - September 13, 2018
« Reply #2 on: September 13, 2018, 10:20:54 pm »
On my Opera browser, on my Android phone, typing in that url brings up the main PLUG web page.

Which url? http or https?
Primary: Desktop Tower with Kubuntu 18.10 on i5-3470 3.2 Ghz with 12 GB RAM, 64 GB SSD for OSes, 4 TB RAID-10 array for programs/data

Secondary/Test: Toshiba Satellite Ultrabook Z830-00K w/ Linux Du Jour, (i3-2367M 1.4 GHz, 4GB DDR3, 128GB SDD)

Offline ssfc72

  • Posting Member
  • Hero Member
  • *
  • Posts: 711
  • Karma: +0/-0
    • View Profile
Re: Main website issues - September 13, 2018
« Reply #3 on: September 13, 2018, 11:07:09 pm »
In the browser address bar , I just typed in plugintolinux.ca
Mint 18.3 on an HP Pavilion X360, 11" k120ca notebook
Cellphone ZTE Axon 7 Mini, PCMobile pay as you go

Offline Jason Wallwork

  • Administrator
  • Hero Member
  • *****
  • Posts: 1365
  • Karma: +4/-0
    • View Profile
Re: Main website issues - September 13, 2018
« Reply #4 on: September 13, 2018, 11:10:14 pm »
When I do that, I end up here:
Primary: Desktop Tower with Kubuntu 18.10 on i5-3470 3.2 Ghz with 12 GB RAM, 64 GB SSD for OSes, 4 TB RAID-10 array for programs/data

Secondary/Test: Toshiba Satellite Ultrabook Z830-00K w/ Linux Du Jour, (i3-2367M 1.4 GHz, 4GB DDR3, 128GB SDD)

Offline Jason Wallwork

  • Administrator
  • Hero Member
  • *****
  • Posts: 1365
  • Karma: +4/-0
    • View Profile
Re: Main website issues - September 13, 2018
« Reply #5 on: September 13, 2018, 11:12:07 pm »
Is anybody getting what I get or does it look normal?
Primary: Desktop Tower with Kubuntu 18.10 on i5-3470 3.2 Ghz with 12 GB RAM, 64 GB SSD for OSes, 4 TB RAID-10 array for programs/data

Secondary/Test: Toshiba Satellite Ultrabook Z830-00K w/ Linux Du Jour, (i3-2367M 1.4 GHz, 4GB DDR3, 128GB SDD)

Offline ssfc72

  • Posting Member
  • Hero Member
  • *
  • Posts: 711
  • Karma: +0/-0
    • View Profile
Re: Main website issues - September 13, 2018
« Reply #6 on: September 13, 2018, 11:24:11 pm »
Maybe something to do with the Chrome browser, you are using.
I use the Opera browser.
Mint 18.3 on an HP Pavilion X360, 11" k120ca notebook
Cellphone ZTE Axon 7 Mini, PCMobile pay as you go

Offline dougal

  • Posting Member
  • Jr. Member
  • *
  • Posts: 98
  • Karma: +0/-0
    • View Profile
Re: Main website issues - September 13, 2018
« Reply #7 on: September 14, 2018, 10:19:29 am »
i typed in plugintolinux.ca and it goes to the HOME page of https ,in chrome Version 68.0.3440.106 (Official Build) (64-bit)

Offline Jason Wallwork

  • Administrator
  • Hero Member
  • *****
  • Posts: 1365
  • Karma: +4/-0
    • View Profile
Re: Main website issues - September 13, 2018
« Reply #8 on: September 14, 2018, 09:22:15 pm »
i typed in plugintolinux.ca and it goes to the HOME page of https ,in chrome Version 68.0.3440.106 (Official Build) (64-bit)

But do you see an error like I see with "Page not Found"?
Primary: Desktop Tower with Kubuntu 18.10 on i5-3470 3.2 Ghz with 12 GB RAM, 64 GB SSD for OSes, 4 TB RAID-10 array for programs/data

Secondary/Test: Toshiba Satellite Ultrabook Z830-00K w/ Linux Du Jour, (i3-2367M 1.4 GHz, 4GB DDR3, 128GB SDD)

Offline Jason Wallwork

  • Administrator
  • Hero Member
  • *****
  • Posts: 1365
  • Karma: +4/-0
    • View Profile
Re: Main website issues - September 13, 2018
« Reply #9 on: September 14, 2018, 10:09:48 pm »
I haven't gotten around to fixing this (if there is a problem with more than just me) but I'll take a closer look this weekend. But please let me know if anybody notices any problems.
Primary: Desktop Tower with Kubuntu 18.10 on i5-3470 3.2 Ghz with 12 GB RAM, 64 GB SSD for OSes, 4 TB RAID-10 array for programs/data

Secondary/Test: Toshiba Satellite Ultrabook Z830-00K w/ Linux Du Jour, (i3-2367M 1.4 GHz, 4GB DDR3, 128GB SDD)

Offline dougal

  • Posting Member
  • Jr. Member
  • *
  • Posts: 98
  • Karma: +0/-0
    • View Profile
Re: Main website issues - September 13, 2018
« Reply #10 on: September 15, 2018, 05:44:40 pm »
no error message...

Offline cod3poet

  • Posting Member
  • Full Member
  • *
  • Posts: 162
  • Karma: +10/-1
  • Brian - Arch Guru
    • View Profile
Re: Main website issues - September 13, 2018
« Reply #11 on: September 15, 2018, 09:33:42 pm »
From the console run

curl http://plugintolinux.ca and see what it returns as the page code that gets output to the console, does it look odd?

Also is this isolated to a single browser?

I only ask as I have tested 4 browsers a piece from 4 machines in 4 geographical locations all with no issue. 16 loads 16 expected results.
Arch, Ubuntu. In that order. (Definitely 04/2018)
i5/8g/256ssd/2tb+30ssd hybrid array
Net+ / Sec+ / VCP

Offline Jason Wallwork

  • Administrator
  • Hero Member
  • *****
  • Posts: 1365
  • Karma: +4/-0
    • View Profile
Re: Main website issues - September 13, 2018
« Reply #12 on: September 15, 2018, 10:11:04 pm »
The error message is embedded within the page, it's not an HTTP error. It's basically a Drupal error (see my screenshot) showing up because the content is being redirected to a page that doesn't exist. Odd that nobody else gets the error, even Dougal who is using Chrome, too, though my version is 69 (specifically
Version 69.0.3497.92 (Official Build) (64-bit) ) for Linux.

I'll leave it for now.
Primary: Desktop Tower with Kubuntu 18.10 on i5-3470 3.2 Ghz with 12 GB RAM, 64 GB SSD for OSes, 4 TB RAID-10 array for programs/data

Secondary/Test: Toshiba Satellite Ultrabook Z830-00K w/ Linux Du Jour, (i3-2367M 1.4 GHz, 4GB DDR3, 128GB SDD)

Offline Jason Wallwork

  • Administrator
  • Hero Member
  • *****
  • Posts: 1365
  • Karma: +4/-0
    • View Profile
Re: Main website issues - September 13, 2018
« Reply #13 on: September 15, 2018, 10:43:32 pm »
Thanks for your testing, guys, especially you Brian with the 16 tests! :)
Primary: Desktop Tower with Kubuntu 18.10 on i5-3470 3.2 Ghz with 12 GB RAM, 64 GB SSD for OSes, 4 TB RAID-10 array for programs/data

Secondary/Test: Toshiba Satellite Ultrabook Z830-00K w/ Linux Du Jour, (i3-2367M 1.4 GHz, 4GB DDR3, 128GB SDD)