Author Topic: Kodak ESP 5250 printer/scanner, page scanning gives I/O error  (Read 377 times)

Offline ssfc72

  • Posting Member
  • Sr. Member
  • *
  • Posts: 330
    • View Profile
This Kodak printer/scanner is apparently supported under SANE.  I am dual booting Mint18 64 bit, on a year 2008 desktop computer, which has an AMD CPU.
The printer function works ok, but when i try to do a page scan, it gives me the I/O error message. The printer/scanner is connected to the computer via USB.

The print and scan works fine under Windoz.

This scanning I/O error message seems to be common complaint, from my internet searches.
Permission issues is one of the possible fixes but from the commands I have issued, to check for this, my permissions are ok.
A lot of the internet postings and fixes are quite old, so I thought maybe newer versions of Mint and SANE may have created new scanning issues, with this older printer.

I finally found a SANE install instruction for this printer/scanner that was dated 2017 and included a recent GitHUB backend  file.
The configure, Make, Make Install, went fine, with no difficulties
Unfortunately, the Simply Scan  and XScan  scanning programs are still reporting an I/O error.

I am beginning to think maybe the older computer hardware is causing the problem.

I will try scanning with this printer connected to my newer notebook computer, running Mint 18, and see if this I/O error persists.

Bill

Offline Jason Wallwork

  • Administrator
  • Sr. Member
  • *****
  • Posts: 489
    • View Profile
Re: Kodak ESP 5250 printer/scanner, page scanning gives I/O error
« Reply #1 on: June 06, 2017, 02:35:40 am »
Try bringing up the scan program with root (or sudo) privileges. If that works, check to see if there is a scan group and then add yourself to it. And then try it again as a regular user.
Jason

Offline ssfc72

  • Posting Member
  • Sr. Member
  • *
  • Posts: 330
    • View Profile
Re: Kodak ESP 5250 printer/scanner, page scanning gives I/O error
« Reply #2 on: June 06, 2017, 06:37:46 am »
Thanks for the suggestion, Jason, but i have been all through the permission checks.  Still get an I/O error running as admin.  All the commands, such as scanimage -L (sudo scanimage -L; sane-find-scanner), shows the printer is found both as user and admin.

I just this evening,hooked the printer/scanner usb cable up to my notebook running Mint 17 64 Bit.  Scanning works perfectly.

I just now booted up from usb thumb drive, a Live Peppermint Distro, on the desktop computer.  Page scanning worked fine!

So it looks maybe, I have to flush out all the Sane related files, in my Mint 18 64 Bit, and start with a fresh install of Sane?
« Last Edit: June 12, 2017, 06:13:57 am by ssfc72 »

Offline Jason Wallwork

  • Administrator
  • Sr. Member
  • *****
  • Posts: 489
    • View Profile
Re: Kodak ESP 5250 printer/scanner, page scanning gives I/O error
« Reply #3 on: June 06, 2017, 05:19:22 pm »
To uninstall the package, it's obvious, of course. But if you want to remove the program and purge the configuration files for a totally clean install, you should do:

Code: [Select]
sudo apt-get purge package
Replace 'package' with whatever the package is called. You can use this command if you're not sure what the package name of the installed program:

Code: [Select]
apt-cache search program
Again, replace 'program' with the name of the program for which you're looking.
Jason

Offline ssfc72

  • Posting Member
  • Sr. Member
  • *
  • Posts: 330
    • View Profile
Re: Kodak ESP 5250 printer/scanner, page scanning gives I/O error
« Reply #4 on: June 09, 2017, 11:04:03 am »
Looks like I will be doing a re-install of Mint 18 64 Bit, on my desktop computer.

I un-installed the SANE and CUPS packages, then re-installed.
Still getting the I/O error and now the Printer menu item has disappeared from the System Settings menu, so I can't re-install the Kodak printer, for printing.  :-(
« Last Edit: June 12, 2017, 06:17:45 am by ssfc72 »

Offline ssfc72

  • Posting Member
  • Sr. Member
  • *
  • Posts: 330
    • View Profile
Re: Kodak ESP 5250 printer/scanner, page scanning gives I/O error
« Reply #5 on: June 11, 2017, 09:36:21 pm »
A further update!

I was looking at re-installing the Mint 18 64 Bit Distro, on the dual boot desktop computer ( a year 2008 box with an AMD Athlon cpu  and Windows Vista 32 Bit)  to try and get my Printer menu back and possibly get the page scanning to work, on the Kodak ESP 5250 printer.

I instead, decided I should boot up a Live Mint 18 64 Bit, from a bootable usb thumb drive.
Turns out the page scanning, using the built in Simple Scan program, still gives an I/O error!!!  So not much point, in trying to re-install Mint 18 64 Bit.

I did have success with page scanning, using an older Live Peppermint Distro on a usb thumb drive (Peppermint ver 6). :-)
I then made up a current, Live version of Peppermint 8 64 Bit  ( version 8 ) on a bootable usb thumb drive and booted that up on the desktop computer.  Simple Scan again, gave an I/O error, when I tried to page scan with the Kodak ESP 5250.

I then made a bootable usb thumb drive with Pepperment 8 32 Bit.  Simple Scan again gave an I/O error and did not scan.

I booted up a Live Peppermint 6 32 Bit from a bootable usb thumb drive and Simple Scan worked fine, for page scanning.

So, until I find a way to get SANE to work with a 64 Bit Distro, for this Kodak 5250 printer,  I will have to use Peppermint 6 32 Bit, for page scanning, when using Linux!

Bill
« Last Edit: June 12, 2017, 06:20:30 am by ssfc72 »

Offline Jason Wallwork

  • Administrator
  • Sr. Member
  • *****
  • Posts: 489
    • View Profile
Re: Kodak ESP 5250 printer/scanner, page scanning gives I/O error
« Reply #6 on: June 12, 2017, 10:19:10 am »
Sounds like perhaps they dropped support for the printer in more recent versions of the SANE backend. If you can find out the version number of it, it might be possible to install the older version of it in Linux Mint so you have support for the scanner feature.
Jason

Offline ssfc72

  • Posting Member
  • Sr. Member
  • *
  • Posts: 330
    • View Profile
Re: Kodak ESP 5250 printer/scanner, page scanning gives I/O error
« Reply #7 on: June 12, 2017, 04:48:31 pm »
On my Acer 1430 notebook computer running Mint 17.2 64 bit, Simple Scan is able to scan a page, on the Kodak 5250 printer, using the usb cable.

On my newer HP Pavilion K120 notebook computer running Mint 18.1, Simple Scan can't scan the page (I/O error), on the Kodak printer.

Offline Jason Wallwork

  • Administrator
  • Sr. Member
  • *****
  • Posts: 489
    • View Profile
Re: Kodak ESP 5250 printer/scanner, page scanning gives I/O error
« Reply #8 on: June 14, 2017, 10:30:17 am »
I mean the version of the SANE software back-end, not the distribution version. It might even just require checking Simple Scan versions. I have Simple Scan on Ubuntu MATE, too but I notice that I don't have SANE installed. So, perhaps it's not used anymore or is somehow rolled into the Simple Scan package. Try this in each version:

Code: [Select]
apt-show-versions simple-scan

If they are different versions, and I suspect that they are, try removing the Simple Scan version that doesn't work with the one that does. This website might help but I will admit I've never done this myself:

https://www.howtogeek.com/117929/how-to-downgrade-packages-on-ubuntu/

But honestly, it's probably easier to use the older Linux Mint version for now if this is an ability you really need. You'll get a year and a half out of it.
Jason

 

SMF spam blocked by CleanTalk