Author Topic: Linux Lite - add to beginner distros?  (Read 149 times)

Offline fox

  • Posting Member
  • Sr. Member
  • *
  • Posts: 434
    • View Profile
Linux Lite - add to beginner distros?
« on: March 31, 2017, 12:43:36 pm »
About a month ago we were talking about beginner distros to recommend to new potential Linux users and one that never got mentioned was Linux Lite. i have no experience with it myself, but in the most recent update posted on DistroWatch, they state: "Linux Lite, a beginner friendly distribution based on Ubuntu. The new version, Linux Lite 3.4, makes it easier to schedule software updates, install third-party drivers and create a restore point for the operating system." The listing on DistroWatch ([urlhttp://distrowatch.com/table.php?distribution=lite](here)[/url] shows a welcome menu that looks to have a lot of the nice features as that of Ubuntu Mate. Do any of you have any experience with Linux Lite? Should it be added to our "beginner distro" section?
Ubuntu 17.04 and 17.10 on 2011 iMac
Linux Mint Cinnamon 18.2 on "late 2015" 5k iMac
Ubuntu 16.04 (Unity, Gnome) and Arch on Dell XPS 13 (4gb RAM, 250gb SSD)

Offline Jason Wallwork

  • Administrator
  • Hero Member
  • *****
  • Posts: 566
    • View Profile
Re: Linux Lite - add to beginner distros?
« Reply #1 on: March 31, 2017, 01:40:54 pm »
I haven't tried it in a while but just on memory, I'd tend to agree. I'll try it out in virtualbox again. But other comments are certainly welcome.
Primary: Desktop Tower with Linux Mint 18.2 Cinnamon on Intel Core i5-3470 3.2 Ghz with 12 GB RAM, 64 GB SSD for OSes, 4 TB RAID 10 array for programs and data and Geforce GT 640 video

Secondary: Toshiba Satellite Z830-00K Ultrabook w/ Intel i3-2367M processor– 1.4 GHz, 4GB DDR3, 128GB SSD

Offline bobf

  • Posting Member
  • Sr. Member
  • *
  • Posts: 284
    • View Profile
Re: Linux Lite - add to beginner distros?
« Reply #2 on: April 11, 2017, 09:51:16 pm »
Definitely! I've been using it on spares for quite awhile now, and seems well-featured and stable. I thought I was having a problem with the distro not being able to handle the new versions of Adobe Flash Player for Linux, but it turns out it's older AMD processors...

 

SMF spam blocked by CleanTalk